愛查股網 www.vuitrj.icu 股票查詢最好股票網 個股數據查詢好股網 手機訪問本頁
| 保存本站網址 | 關閉站內廣告
愛查股網
股票查詢最好股票網 個股數據查詢好股網
您的位置:愛查股網 > 股票公式 > 大智慧公式
股票行情查詢:

大智慧黃藍階梯主圖指標公式

2019/5/30 21:53:13

N1:=5;
N2:=20;
JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
ma5:ma(c,n1);
ma20:=ma(c,n2);
{MA6:MA(CLOSE,P4),linethick2,colorCC9900;
MA7:MA(CLOSE,P5),linethick2;
MA8:MA(CLOSE,P6),linethick2,colorcyan;}
STICKLINE(A>B,A,B,9,0),COLOR0099FF{colorgreen};
STICKLINE(A買入:cross(a,b),LINETHICK0;
買入天數:last(a>b),LINETHICK0;
{=====================================}
DRAWTEXTABS(2,6,'所屬板塊:'+BKNAME),COLORblack,linethick1;
每股凈資產:=FINANCE2(4);
銷售毛利率:=FINANCE2(12);
主營收入同比:=FINANCE2(11);
凈利潤同比:=FINANCE2(10);
DRAWTEXTABS(118,21,'每股凈資產:'+NUMTOSTRN(每股凈資產,2)+'元'),COLORRED;
DRAWTEXTABS(2,21,'銷售毛利率:'+NUMTOSTRN(銷售毛利率,2)+'%'),LINETHICK1,COLORblue;
DRAWTEXTABS(2,39,'主營收入同比:'+NUMTOSTRN(主營收入同比,2)+'%'),LINETHICK1,Colorblack;
DRAWTEXTABS(2,54,'凈利潤同比:'+NUMTOSTRN(凈利潤同比,2)+'%'),LINETHICK1,COLOR006633;
DRAWTEXTABS(3,69,'最高價:'+HHV(HIGH,0)),Colorred;
DRAWTEXTABS(3,84,'最低價:'+LLV(LOW,0)),Colorff0099;
{******************************}
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
SK:= EMA(Var1,13)-EMA(Var1,73);
SD:= EMA(SK,2);
drawtext((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 )
or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)) ,l*0.99,'短線'),colorff0099;
stickline((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 )
or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)),h,l,0.5,0),colorred;
stickline((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 )
or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)),o,c,10,1),linethick3,colorred;
{===================================================================}
{將上面的源碼復制粘貼到任意主圖即可};
DA:=6;FA:=5;CT:=1;P:=0;N:=3;
MM:=IF(((P=0) OR (VOL=0)),MA(CLOSE,N1),((SUM(AMOUNT,N1)/SUM(VOL,N1))/100));
M1:=REF(MM,1);
買入:=IF(CROSS(CLOSE,M1),M1,0);
賣出:=IF(CROSS(M1,CLOSE),M1,0);
DW:=BARSLAST((賣出>0));
EX10:=HHV((買入>0),(DW+1));
BJ:=IF((EX10>REF(EX10,1)),買入,0);
SJ:=IF((EX10STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,5.28,0), COLOR0044FF;
STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,2.6,0), COLOR0077FF;
STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,2.2,0), COLOR1199FF;
STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1.8,0), COLOR22BBFF;
STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1.4,0), COLOR33DDFF;
STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1,0), COLOR33FFFF;
STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,3,0), COLOR000055;
STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,2.6,0), COLOR000077;
STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,2.2,0), COLOR000099;
STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1.8,0), COLOR0000BB;
STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1.4,0), COLOR0000DD;
STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1,0), COLOR0033FF;
STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,5.580,0),COLORFF4400;
STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,2.6,0),COLORFF7700;
STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,2.2,0),COLORFF9911;
STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,1.8,0),COLORFFBB22;
STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,1.4,0),COLORFFDD33;
STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,1,0),COLORFFFF33;
STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,3.0,0),COLOR550000;
STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,2.6,0),COLOR770000;
STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,2.2,0),COLOR990000;
STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,1.8,0),COLORBB0000;
STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,1.4,0),COLORDD0000;
STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,1,0),COLORFF0000;
{分倉管理}{主圖疊加}{大智慧L2公式macd}
q1:=(IF(DATE > 1341231,0,1));
a43:=(q1 * (BARSLAST(DISPSTATUS = 1) + 1));
a44:=(LLVALL(LLV(L,a43)));
a65:=(TROUGHBARS(3,15,1) < 4);
a66:=(EMA((C - MA((2 * C + H + L) / 4,30)) / MA((2 * C + H + L) / 4,30) * 100,3));
a67:=(FILTER(a65 = 1,5));
a68:=(FILTER(a65 = 1,5) and a66 < -10);
a69:=(FILTER(a65 = 1,3));
DRAWTEXT(REF(a69,1) = 0 and REF(a69,2) = 1,a44 * 0.99,'★'),linethick5,VALIGN2,ALIGN1,ColorFF9900;
{====================================}
AR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
DRAWTEXT(AR13,c*0.958,'●'), COLORRED;
AR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
DRAWTEXT(AR17,c*0.958,'發現黑馬'), COLORBROWN;
{********************************}
A5:=EMA(CLOSE,12)-EMA(CLOSE,26);
A6:=EMA(A5,9);
A7:=(A5<-0.1 AND A5>A6);
龍王:IF(A7,LLV(L,21),ma20),{COLOR888888,CIRCLEDOT}POINTDOT,COLORred,LINETHICK3;
;{將上面的源碼復制粘貼到任意主圖即可};
PARTLINE(ma20,ma20>ref(ma20,1),RGB(255,0,0),ma20{========================================================================}
{火眼金睛}
上:=(SMA(HIGH,21,2) * 1.05);
下軌道:=(SMA(LOW,21,2) * 0.969);
RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) - (2 * D24));
支撐位:=IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24))));
壓力位:=IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J))));
L2L:=IF((CLOSE >= MA(CLOSE,20)),50,20);
RL1:=IF(((J > L2L) AND (REF(J,1) <= L2L)),LLV(REF(LOW,1),(BARSLAST(((J <= L2L) AND (REF(J,1) > L2L))) - 1)),REF(LLV(REF(LOW,1),(BARSLAST(((J <= L2L) AND (REF(J,1) > L2L))) - 1)),BARSLAST(((J > L2L) AND REF(J,1)))));
RL4:=IF((LOW < RL1),HIGH,REF(HIGH,BARSLAST((LOW < RL1))));
RL42:=IF((LOW < RL1),J,REF(J,BARSLAST((LOW < RL1))));
RL5:=IF((((LOW < RL4) AND (J > RL42)) AND (J > J24)),LOW,REF(LOW,BARSLAST((((LOW < RL4) AND (J > RL42)) AND (J > J24)))));
CB:=((AMOUNT / VOL) / 100);
CD:=((CB > HIGH) OR (CB < LOW));
黑馬趨勢:=MA(CLOSE,3);
AA10:=MA(CLOSE,8);
DRAWTEXT(FILTER(((((((CLOSE / OPEN) > 1.04) AND ((CLOSE - REF(CLOSE,1)) > 0)) AND (CLOSE > 下軌道)) AND ((AA10 - REF(AA10,1)) > 0)) AND (CLOSE < 上)),3),(LOW - 0.05),'▲追'),color00ff00;
短期底部:=LLV(OPEN,30);
DRAWTEXT(((((((CROSS(黑馬趨勢,短期底部) AND ((RL5 - REF(RL5,1)) > 0)) AND ((黑馬趨勢 - REF(黑馬趨勢,1)) > 0)) AND (黑馬趨勢 > 1)) AND (LOW <= 支撐位)) AND (CLOSE > 支撐位)) AND (HIGH < 壓力位)),(LOW - 0.15),'←黑馬發現'),colorFF00FF;
DRAWTEXT((((((((CROSS(黑馬趨勢,RL5) AND ((黑馬趨勢 - REF(黑馬趨勢,1)) > 0)) AND (HIGH < 壓力位)) AND (LOW <= 短期底部)) AND (CLOSE > 支撐位)) AND (CD < 1)) AND (CLOSE > OPEN)) AND (CLOSE > RL5)),LOW,'←短買'),colorBLUE;
VAR5:=(((HHV(HIGH,36) - CLOSE) / (HHV(HIGH,36) - LLV(LOW,36))) * 100);
VAR6:=SMA(VAR5,5,1);
VAR7:=SMA(VAR6,8,1);
VAR8:=(CROSS(VAR6,VAR7) AND (VAR7 < 16));
VAR9:=((CLOSE > (LLV(CLOSE,60) + (0.3 * LLV(CLOSE,60)))) AND VAR8);
VARA:=IF((CLOSE > 1000),VAR8,VAR9);
逃遁:=VARA;
DRAWTEXT(VARA,HIGH+0.06,'▼逃遁'),color006633;
趨勢線:=3*SMA((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
底部:=LLV(CLOSE,30);
ma3:=MA(底部,2);
x:=MA(CLOSE,26);
壓力:=HHV(HIGH,30);
DRAWTEXT(FILTER(LOW<=x and CLOSE>=x and ma3>=REF(ma3,1)and CLOSE/OPEN>1.02 and WINNER(CLOSE)<0.4,20),c*0.9285,'看多'),color993399;
DRAWTEXT(FILTER(HIGH>=壓力 and CLOSE1.03 and WINNER(CLOSE)>0.6,5),HIGH + 0.06,'壓力'),colorgreen;
短期乖離率:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
DRAWTEXT(FILTER(IF(CROSS(趨勢線,10)and CLOSE/LOW>1.04 and 短期乖離率<0.35 ,1,0)and CLOSE>OPEN,5),LOW-0.07,'底'),COLORRED;
{**********************************};歷史大底:DRAWTEXT(FILTER((((((LLV(LOW,0) AND (WINNER(CLOSE) < 0.08)) AND (LOW <= 短期底部)) AND (CLOSE > 短期底部)) AND (J < 80)) AND ((CLOSE / OPEN) > 1.08)),20),(LOW - 0.288),'★★歷史大底');
cj2:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
cj3:=(CLOSE-cj2)/cj2*100;
cj4:=REF(cj3,1)<-40 AND cj3>REF(cj3,1) AND REF(cj3,1)2.5;
cj5:=(CLOSE-OPEN)/OPEN*100;
cj6:=REF(CLOSE,1);
cj7:=SMA(MAX(CLOSE-cj6,0),6,1)/SMA(ABS(CLOSE-cj6),6,1)*100;
cj8:=COUNT(cj7<20,20)>=1;
cj9:=cj5>9 AND cj8;
cjA:=100*WINNER(OPEN);
cjB:=100*WINNER(CLOSE);
cjC:=cjB-cjA;
cjD:=cjC>=30;
cjE:=CLOSE/MA(CLOSE,3)>=1.07 AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
cjF:=REF(CLOSE,1);
cj10:=SMA(MAX(CLOSE-cjF,0),5,1)/SMA(ABS(CLOSE-cjF),5,1)*100;
cj11:=COUNT(cj10<20,20)>=1;
cj12:=cjE AND cj11;
cj13:=MA(CLOSE,4);
cj14:=MA(CLOSE,10);
cj15:=MA(CLOSE,20);
cj16:=MA(CLOSE,25);
cj17:=COUNT(CROSS(cj14,cj15),2)=1;
cj18:=COUNT(CROSS(cj13,cj16),2)=1;
cj19:=cj17 AND cj18;
cj1A:=cj12 AND cjD AND cj19;
cj1B:=MA(CLOSE,80)-MA(CLOSE,10)/3;
cj1C:=CLOSEMA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE短底反彈:=cj4 OR cj9 OR cj1A OR cj1C;
ls:=c/ref(c,1)>1.048 and c=h and between(forcast(V,4),0.2*forcast(v,12),2.1*forcast(v,12));
拉升:=filter(ls,28)*100;
DRAWTEXT(短底反彈,low*0.978,'●短底'),linethick1,{colorffffff}colorff00ff;
{捉妖記} {主圖指標}
{VAR4:=(((((REF(C,1)) * (1.1)) - C) < (0.01)) AND (H = C));
E5:=(EMA(C,5));
VAR5:=((20 * H + 19 * (REF(H,1)) + 18 * (REF(H,2)) + 17 * (REF(H,3)) + 16 * (REF(H,4)) + 15 * (REF(H,5)) + 14 * (REF(H,6)) + 13 * (REF(H,7)) + 12 * (REF(H,8)) + 11 * (REF(H,9)) + 10 * (REF(H,10)) + 9 * (REF(H,11)) + 8 * (REF(H,12)) + 7 * (REF(H,13)) + 6 * (REF(H,14)) + 5 * (REF(H,15)) + 4 * (REF(H,16)) + 3 * (REF(H,17)) + 2 * (REF(H,18)) + REF(H,20)) / (210));
VAR6:=(EMA(VAR5,90));
妖股線:(VAR6 + (((C - (VAR6)) * C) - (VAR6)) / (VAR6)),LINETHICK2,colorFF00FF;
VAR8:=(CROSS(妖股線,E5));
DRAWTEXT((VAR8) AND (VAR4),L,'↖超級主升'),LINETHICK3,COLORRED;};

股票公式推薦
在線查股
個股查股導航:股票行情查詢 DDX在線查詢 超贏數據查詢 資金流向 千股千評 個股最新消息 大小非解禁 十大股東查詢 分紅配股查詢 業績預告查詢
艾華集團 603989+1.83% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
盛洋科技 603703+1.83% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
*ST菲達 600526+1.83% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
思源電氣 002028+1.81% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
廣哈通信 300711+1.81% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
中飛股份 300489+1.80% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
江海股份 002484+1.79% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
馳宏鋅鍺 600497+1.79% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
大冶特鋼 000708+1.78% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
*ST索菱 002766+1.77% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
商務合作:在線客服
愛查股網不推薦股票,不收會員,網站內的廣告不代表本股票網的觀點,由此引起的一切法律責任均與本站無關,股市有風險,投資需謹慎。粵ICP備17111814號-1
特別提示:本站不為所提供數據的錯誤、殘缺、延遲或因依靠此信息所采取的任何行為負責。本股票網提供的所有內容僅供參考,不構成投資建議,投資者據此操作,風險自擔。
手機版(手機訪問當前頁面) | 電腦端(適合電腦或大屏用戶)
福建时时记录